Help!

Vista x64 can ping, but can't browse or get email / messen..

 
Post new topic   General Reply to Topic (not reply to a specific post)    Forums Home -> Networking & Sharing RSS
Next:  Vista Slow to Connect  
Author Message
Dickson
External


Since: Aug 07, 2007
Posts: 3



PostPosted: Tue Aug 07, 2007 11:46 pm    Post subject: Vista x64 can ping, but can't browse or get email / messenger
Archived from groups: microsoft>public>windows>vista>networking_sharing (more info?)

Hello everyone,

I've a Vista Ultimate x64 OS, which used already 6 months without problem,
but since yesterday I've encounter a blue screen (with locked process error),
When I restart the computer, The OS said one of my network component have
problem,
and it recommend me to remove it, I've click the fix button and then when it
done,
I can ping my router, yahoo.com (not IP) and other website.
However I can't connect to Live messenger, email, or browse any website.
(even my router admin page, eg. 192.168.1.1)

I've tried remove the network card driver and reinstall it but it does
nothing,
I've also reinstall all avaliable network service and protocol / client for
the network adapter,
and changed my fix private IP to use DHCP, it get an IP, can ping yahoo.com,
but can't browse internet or use messenger.

I've also use the system restore to a state to few days before, but same
problem exist.

Even I can't browse Internet, I can share files within my home network
(It can browse other PC using network place)

I've switch to another OS (dualboot, XP Pro 32bit) on this PC,
it can browse Internet without problem.

I've other PC using XP and 2000 can browse internet using both fix private
ip and DHCP.

I think this may be a network socket problem, but I can't figure it out,
Does any one have any solution for this?

----

Here's my Network equipment.

PC1: Vista x64, Win XP Pro
PC2: Win XP Pro
PC3: Win 2000
Router: Linksys RV042
Switch: 3com 8-port Gigabits Switch (w/Jumbo Frame)

Thanks!

Dickson
Best Rgds.
Back to top
Spirit
External


Since: May 19, 2007
Posts: 233



PostPosted: Wed Aug 08, 2007 12:18 am    Post subject: Re: Vista x64 can ping, but can't browse or get email / messenger [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

Spyware?

Set Firewall to ALLOW ALL

TCP/IP Receive Window Auto Tuning
http://www.vistax64.com/tutorials/72308-auto-tuning-tcp-ip-receive-level.html

"Dickson" wrote in message


> Hello everyone,
>
> I've a Vista Ultimate x64 OS, which used already 6 months without
> problem,
> but since yesterday I've encounter a blue screen (with locked process
> error),
> When I restart the computer, The OS said one of my network component have
> problem,
> and it recommend me to remove it, I've click the fix button and then when
> it
> done,
> I can ping my router, yahoo.com (not IP) and other website.
> However I can't connect to Live messenger, email, or browse any website.
> (even my router admin page, eg. 192.168.1.1)
>
> I've tried remove the network card driver and reinstall it but it does
> nothing,
> I've also reinstall all avaliable network service and protocol / client
> for
> the network adapter,
> and changed my fix private IP to use DHCP, it get an IP, can ping
> yahoo.com,
> but can't browse internet or use messenger.
>
> I've also use the system restore to a state to few days before, but same
> problem exist.
>
> Even I can't browse Internet, I can share files within my home network
> (It can browse other PC using network place)
>
> I've switch to another OS (dualboot, XP Pro 32bit) on this PC,
> it can browse Internet without problem.
>
> I've other PC using XP and 2000 can browse internet using both fix private
> ip and DHCP.
>
> I think this may be a network socket problem, but I can't figure it out,
> Does any one have any solution for this?
>
> ----
>
> Here's my Network equipment.
>
> PC1: Vista x64, Win XP Pro
> PC2: Win XP Pro
> PC3: Win 2000
> Router: Linksys RV042
> Switch: 3com 8-port Gigabits Switch (w/Jumbo Frame)
>
> Thanks!
>
> Dickson
> Best Rgds.
Back to top
Dickson
External


Since: Aug 07, 2007
Posts: 3



PostPosted: Wed Aug 08, 2007 12:44 am    Post subject: Re: Vista x64 can ping, but can't browse or get email / messenger [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

Hello Spirit,

Thanks for the reply, since I'm not at home, I can't try the solution you
provided yet, I'll try it later today.

Yesterday, I've already disabled the windows firewall and allowed all
traffic in/out at the router, but the same problem still exist.

Some additional information:
When I tried to use Internet Explorer or Firefox to browse webpage, It
just show "the page cannot display" etc.,
and then, when I close the IE or Firefox, they both crash, and windows error
report manager popups,
however, the error report manager crash too.
And then, the OS tell me DEP (Data Execution Prevention) have stopped the
error report manager.

This make me confuse.

Dickson
Best Rgds.

"Spirit" wrote:

> Spyware?
>
> Set Firewall to ALLOW ALL
>
> TCP/IP Receive Window Auto Tuning
> http://www.vistax64.com/tutorials/72308-auto-tuning-tcp-ip-receive-level.html
>
> "Dickson" wrote in message
>
>
> > Hello everyone,
> >
> > I've a Vista Ultimate x64 OS, which used already 6 months without
> > problem,
> > but since yesterday I've encounter a blue screen (with locked process
> > error),
> > When I restart the computer, The OS said one of my network component have
> > problem,
> > and it recommend me to remove it, I've click the fix button and then when
> > it
> > done,
> > I can ping my router, yahoo.com (not IP) and other website.
> > However I can't connect to Live messenger, email, or browse any website.
> > (even my router admin page, eg. 192.168.1.1)
> >
> > I've tried remove the network card driver and reinstall it but it does
> > nothing,
> > I've also reinstall all avaliable network service and protocol / client
> > for
> > the network adapter,
> > and changed my fix private IP to use DHCP, it get an IP, can ping
> > yahoo.com,
> > but can't browse internet or use messenger.
> >
> > I've also use the system restore to a state to few days before, but same
> > problem exist.
> >
> > Even I can't browse Internet, I can share files within my home network
> > (It can browse other PC using network place)
> >
> > I've switch to another OS (dualboot, XP Pro 32bit) on this PC,
> > it can browse Internet without problem.
> >
> > I've other PC using XP and 2000 can browse internet using both fix private
> > ip and DHCP.
> >
> > I think this may be a network socket problem, but I can't figure it out,
> > Does any one have any solution for this?
> >
> > ----
> >
> > Here's my Network equipment.
> >
> > PC1: Vista x64, Win XP Pro
> > PC2: Win XP Pro
> > PC3: Win 2000
> > Router: Linksys RV042
> > Switch: 3com 8-port Gigabits Switch (w/Jumbo Frame)
> >
> > Thanks!
> >
> > Dickson
> > Best Rgds.
>
>
Back to top
Dickson
External


Since: Aug 07, 2007
Posts: 3



PostPosted: Wed Aug 08, 2007 11:22 am    Post subject: Re: Vista x64 can ping, but can't browse or get email / messenger [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

Hello Robert

Thanks for the reply,
after I reset the winsock file and restarted the computer,
I can now browse website and read email without any problem.

Thankyou very much!

Best Rgds.
Dickson


> Try to reset the Winsock file:
>
> 1. Click Start , type cmd in the Start Search text box, and then
> press ENTER.
> 2. Type the following command, and then press ENTER:
> netsh winsock reset
> 3. Restart the computer.
>
>
Back to top
ginfest
External


Since: Feb 19, 2007
Posts: 11



PostPosted: Wed Aug 08, 2007 11:42 am    Post subject: Re: Vista x64 can ping, but can't browse or get email / messenger [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

"Dickson" wrote in message

> Hello Robert
>
> Thanks for the reply,
> after I reset the winsock file and restarted the computer,
> I can now browse website and read email without any problem.
>
> Thankyou very much!
>
> Best Rgds.
> Dickson
>
>
>> Try to reset the Winsock file:
>>
>> 1. Click Start , type cmd in the Start Search text box, and then
>> press ENTER.
>> 2. Type the following command, and then press ENTER:
>> netsh winsock reset
>> 3. Restart the computer.
>>
>>

Thank you very much, I had the same problem and just couldn't sort it. Glad
that I saw this b4 I reinstalled Vista!
Back to top
grego87



Joined: Sep 29, 2008
Posts: 1



PostPosted: Mon Sep 29, 2008 9:02 pm    Post subject: Re: Vista x64 can ping, but can't browse or get email / mes [Login to view extended thread Info.]

robert.stojanov wrote:
Try to reset the Winsock file:

1. Click Start , type cmd in the Start Search text box, and then
press ENTER.
2. Type the following command, and then press ENTER:
netsh winsock reset
3. Restart the computer.

I know this is an old thread but I just needed to thank you for this info.
The same happened to my brother, where only 64 bit programs could use the connection like IE7 64-bit , so he had to install the 32 bit version.
It saved me from downgrading to 32 bit version and installing all the software back again.

Thank you Very Happy
Back to top
x1234



Joined: Apr 05, 2009
Posts: 1



PostPosted: Mon Apr 06, 2009 2:03 am    Post subject: [Login to view extended thread Info.]

Yes, while this is an old thread, this solution also worked for me with the same symptoms in Windows XP.

Thank you!
Back to top
Display posts from previous:   
Post new topic   General Reply to Topic (not reply to a specific post)    Forums Home -> Networking & Sharing All times are: Eastern Time (US & Canada)
Page 1 of 1

 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum