Help!

Hyperlinks in a multi-page mht file

 
Post new topic   General Reply to Topic (not reply to a specific post)    Forums Home -> General Discussions RSS
Next:  upgraded from 03 to 07 - now cannot have multiuse..  
Author Message
atryon
External


Since: Jan 13, 2009
Posts: 1



PostPosted: Tue Jan 13, 2009 5:36 pm    Post subject: Hyperlinks in a multi-page mht file
Archived from groups: microsoft>public>publisher (more info?)

Please forgive my post if this is the incorrect forum, I'm looking for help
with troubleshooting links in a .mht file. I'm using Publisher 2003, SP2 and
running IE 6.0.2900

I have a 4-page mht document and pages 1, 3 and 4 have intra-page links
(links to other places on the same page) as well as the standard navigation
links between the 4 pages. All the standard hyperlinks work. All the
html-fragment links work on page 1, but on pages 3 and 4, the html-fragment
links to other sections of those pages don't work, they just give a "Page
could not be displayed error".

This is an example of a header on page 4:
<h2><a name="Question21"></a></h2>

and the related link also on page 4:
<a href="#Question21"> Question 2.1 </a>

Maybe my html code is off, but I made almost identical headers and
references on page 1 (different names) and those links worked fine.
The other weird thing is that when I use Web-Page Preview, all links
work fine on all pages. It's only when I've saved the file and I am actually
opening it to view it that the links don't work. I've scoured the forums and
can't seem to find anyone else with this issue, I also checked out the MSMVP
blogs and just a regular web-search with no luck. Any help would be greatly
appreciated.
Back to top
DavidF
External


Since: Mar 18, 2004
Posts: 3066



PostPosted: Tue Jan 13, 2009 9:08 pm    Post subject: Re: Hyperlinks in a multi-page mht file [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

See the web group for a response.

DavidF

"atryon" wrote in message

> Please forgive my post if this is the incorrect forum, I'm looking for
> help
> with troubleshooting links in a .mht file. I'm using Publisher 2003, SP2
> and
> running IE 6.0.2900
>
> I have a 4-page mht document and pages 1, 3 and 4 have intra-page links
> (links to other places on the same page) as well as the standard
> navigation
> links between the 4 pages. All the standard hyperlinks work. All the
> html-fragment links work on page 1, but on pages 3 and 4, the
> html-fragment
> links to other sections of those pages don't work, they just give a "Page
> could not be displayed error".
>
> This is an example of a header on page 4:
> <h2><a name="Question21"></a></h2>
>
> and the related link also on page 4:
> <a href="#Question21"> Question 2.1 </a>
>
> Maybe my html code is off, but I made almost identical headers and
> references on page 1 (different names) and those links worked fine.
> The other weird thing is that when I use Web-Page Preview, all links
> work fine on all pages. It's only when I've saved the file and I am
> actually
> opening it to view it that the links don't work. I've scoured the forums
> and
> can't seem to find anyone else with this issue, I also checked out the
> MSMVP
> blogs and just a regular web-search with no luck. Any help would be
> greatly
> appreciated.
>
>
Back to top
Display posts from previous:   
Post new topic   General Reply to Topic (not reply to a specific post)    Forums Home -> General Discussions All times are: Eastern Time (US & Canada)
Page 1 of 1

 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum